58 lines
1.8 KiB
Diff
58 lines
1.8 KiB
Diff
Upstream-Status: Pending
|
|
|
|
Use the defaults.h in ${B} instead of ${S}, and t-oe in ${B}, so that
|
|
the source can be shared between gcc-cross-initial,
|
|
gcc-cross-intermediate, gcc-cross, gcc-runtime, and also the sdk build.
|
|
---
|
|
gcc/Makefile.in | 2 +-
|
|
gcc/configure | 4 ++--
|
|
gcc/configure.ac | 4 ++--
|
|
3 files changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/gcc/Makefile.in b/gcc/Makefile.in
|
|
index d91f93a..03ee2bd 100644
|
|
--- a/gcc/Makefile.in
|
|
+++ b/gcc/Makefile.in
|
|
@@ -461,7 +461,7 @@ LIMITS_H_TEST = [ -f $(SYSTEM_HEADER_DIR)/limits.h ]
|
|
TARGET_SYSTEM_ROOT = @TARGET_SYSTEM_ROOT@
|
|
|
|
xmake_file=@xmake_file@
|
|
-tmake_file=@tmake_file@
|
|
+tmake_file=@tmake_file@ ./t-oe
|
|
TM_ENDIAN_CONFIG=@TM_ENDIAN_CONFIG@
|
|
TM_MULTILIB_CONFIG=@TM_MULTILIB_CONFIG@
|
|
TM_MULTILIB_EXCEPTIONS_CONFIG=@TM_MULTILIB_EXCEPTIONS_CONFIG@
|
|
diff --git a/gcc/configure b/gcc/configure
|
|
index f440fa2..dafb0c1 100755
|
|
--- a/gcc/configure
|
|
+++ b/gcc/configure
|
|
@@ -10838,8 +10838,8 @@ for f in $tm_file; do
|
|
tm_include_list="${tm_include_list} $f"
|
|
;;
|
|
defaults.h )
|
|
- tm_file_list="${tm_file_list} \$(srcdir)/$f"
|
|
- tm_include_list="${tm_include_list} $f"
|
|
+ tm_file_list="${tm_file_list} ./$f"
|
|
+ tm_include_list="${tm_include_list} ./$f"
|
|
;;
|
|
* )
|
|
tm_file_list="${tm_file_list} \$(srcdir)/config/$f"
|
|
diff --git a/gcc/configure.ac b/gcc/configure.ac
|
|
index d003091..ba422e6 100644
|
|
--- a/gcc/configure.ac
|
|
+++ b/gcc/configure.ac
|
|
@@ -1652,8 +1652,8 @@ for f in $tm_file; do
|
|
tm_include_list="${tm_include_list} $f"
|
|
;;
|
|
defaults.h )
|
|
- tm_file_list="${tm_file_list} \$(srcdir)/$f"
|
|
- tm_include_list="${tm_include_list} $f"
|
|
+ tm_file_list="${tm_file_list} ./$f"
|
|
+ tm_include_list="${tm_include_list} ./$f"
|
|
;;
|
|
* )
|
|
tm_file_list="${tm_file_list} \$(srcdir)/config/$f"
|
|
--
|
|
1.7.1
|
|
|