55 lines
2.0 KiB
BlitzBasic
55 lines
2.0 KiB
BlitzBasic
SUMMARY = "ALSA sound library"
|
|
HOMEPAGE = "http://www.alsa-project.org"
|
|
BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php"
|
|
SECTION = "libs/multimedia"
|
|
LICENSE = "LGPLv2.1 & GPLv2+"
|
|
LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
|
|
file://src/socket.c;beginline=1;endline=26;md5=11ff89a8a7a4a690a5c78effe8159545"
|
|
|
|
BBCLASSEXTEND = "native nativesdk"
|
|
|
|
# configure.in sets -D__arm__ on the command line for any arm system
|
|
# (not just those with the ARM instruction set), this should be removed,
|
|
# (or replaced by a permitted #define).
|
|
#FIXME: remove the following
|
|
ARM_INSTRUCTION_SET = "arm"
|
|
|
|
SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/${BP}.tar.bz2 \
|
|
file://Check-if-wordexp-function-is-supported.patch \
|
|
file://fix-tstamp-declaration.patch \
|
|
file://0001-pcm-route-Use-get32-for-multi-source-route-calculati.patch \
|
|
file://0001-pcm-rate-fix-hw_ptr-exceed-the-boundary.patch \
|
|
file://0001-pcm-pcm_local.h-include-time.h-to-enable-CLOCK_MONOT.patch \
|
|
"
|
|
SRC_URI[md5sum] = "c9e21b88a2b3e6e12ea7ba0f3b271fc3"
|
|
SRC_URI[sha256sum] = "3c074b85dde1b30e78ef4995579765833e5b693fbbd8f834c335e080cb734a6d"
|
|
|
|
inherit autotools pkgconfig
|
|
|
|
require alsa-fpu.inc
|
|
EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
|
|
|
|
EXTRA_OECONF = "--disable-python"
|
|
|
|
EXTRA_OECONF_append_libc-uclibc = " --with-versioned=no "
|
|
|
|
PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc"
|
|
FILES_${PN} += "${libdir}/${BPN}/smixer/*.so"
|
|
FILES_${PN}-dbg += "${libdir}/${BPN}/smixer/.debug"
|
|
FILES_${PN}-dev += "${libdir}/${BPN}/smixer/*.la"
|
|
FILES_libasound = "${libdir}/libasound.so.*"
|
|
FILES_alsa-server = "${bindir}/*"
|
|
FILES_alsa-conf = "${datadir}/alsa/"
|
|
FILES_alsa-conf-base = "\
|
|
${datadir}/alsa/alsa.conf \
|
|
${datadir}/alsa/cards/aliases.conf \
|
|
${datadir}/alsa/pcm/default.conf \
|
|
${datadir}/alsa/pcm/dmix.conf \
|
|
${datadir}/alsa/pcm/dsnoop.conf"
|
|
|
|
RDEPENDS_libasound = "alsa-conf-base alsa-conf"
|
|
# upgrade path
|
|
RPROVIDES_${PN}-dev = "alsa-dev"
|
|
RREPLACES_${PN}-dev = "alsa-dev"
|
|
RCONFLICTS_${PN}-dev = "alsa-dev"
|