17 lines
661 B
BlitzBasic
17 lines
661 B
BlitzBasic
require ${BPN}.inc
|
|
|
|
SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
|
|
|
|
SRC_URI[md5sum] = "62faf98ac79c5587f8e917e187419e6c"
|
|
SRC_URI[sha256sum] = "f18a967e9c4d80e054b2fdff8c130ce6e6d1f8eecfc42c9f354f8628d8b4df1c"
|
|
|
|
S = "${WORKDIR}/Mesa-${PV}"
|
|
|
|
#because we cannot rely on the fact that all apps will use pkgconfig,
|
|
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
|
|
do_install_append() {
|
|
if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
|
|
sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
|
|
fi
|
|
}
|