26 lines
806 B
BlitzBasic
26 lines
806 B
BlitzBasic
DESCRIPTION = "Ntfs-3g for NAS"
|
|
HOMEPAGE = "https://security.appspot.com/ntfs-3g.html"
|
|
LICENSE = "GPLv3"
|
|
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
|
|
SRC_URI = " \
|
|
https://security.appspot.com/downloads/ntfs-3g.tar.gz \
|
|
"
|
|
SRC_URI[md5sum] = "a3b3ebdece45543b41a129cd5a0b0431"
|
|
SRC_URI[sha256sum] = "e3e537358aa06124856c3f13d0e120ba2a3351ea97ab584d71b0efa2c3ea373e"
|
|
S = "${WORKDIR}/${PN}"
|
|
|
|
PR = "r0"
|
|
|
|
inherit autotools-brokensep
|
|
|
|
do_configure() {
|
|
./configure --build=${BUILD_SYS} --host=${HOST_SYS} --target=${TARGET_SYS} --prefix=${prefix}
|
|
}
|
|
|
|
do_install() {
|
|
install -d ${D}${bindir} ${D}/usr/lib
|
|
install -m 0755 ${S}/src/.libs/ntfs-3g ${D}${bindir}
|
|
install -m 0755 ${S}/libntfs-3g/.libs/libntfs-3g.so.83.0.0 ${D}/usr/lib/libntfs-3g.so.83
|
|
}
|
|
|